Author Topic: Weird "Error"  (Read 591 times)

0 Members and 1 Guest are viewing this topic.

Offline Brucia

  • Knight
  • ***
  • Renown: 29
  • Infamy: 2
  • cRPG Player
    • View Profile
Weird "Error"
« on: December 21, 2017, 12:12:37 AM »
+1
Hello,
since i was experiencing a weird "Error" with the auto update of the (very)old launcher, i decided to re download the latest version of crpg as can be found on crpg.net.

Unfortunately, as soon as i double clicked on the launcher, this "Error" came up (it could even be the same error i had found at the end of the auto update):

---------------------------
Critical error
---------------------------
Impossibile trovare il metodo '!!0[] System.Array.Empty()'.

System.MissingMethodException
   in cRPGLauncher.FormMain.UpdateLauncher(Boolean firstTry)

   in cRPGLauncher.FormMain.FormMain_Shown(Object sender, EventArgs e)

   in System.Windows.Forms.Form.OnShown(EventArgs e)

   in System.Windows.Forms.Form.CallShownEvent()

   in System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)

   in System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)

   in System.Threading.ExecutionContext.runTryCode(Object userData)

   in System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)

   in System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)

   in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)

   in System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)

   in System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)

   in System.Windows.Forms.Control.InvokeMarshaledCallbacks()


What should i do?

Offline Uther Pendragon

  • Supreme Overlord
  • *******
  • Renown: 1247
  • Infamy: 133
  • cRPG Player A Gentleman and a Scholar
  • Head of EU and NA admin teams
    • View Profile
    • Strategus Guide
  • Faction: Stromgarde
  • Game nicks: Uthyr Pendraeg, Uthyr, mr fucking dtv hero admin, Stromgarde_Uthyr_Pendraeg
  • IRC nick: Something along those lines above
Re: Weird "Error"
« Reply #1 on: December 21, 2017, 12:24:29 AM »
+2
I'm almost 100% sure you want to download this https://www.microsoft.com/net/download/thank-you/net471 and install it. Please report if it's successful!
Nemo prudens punit, quia peccatum est, sed ne peccetur.
I manage character issues, reverting, restoring and fixing related mistakes and some other stuff. Feel free to message if you encounter a problem.
He's not the hero DTV deserves but he's the one they need.

Offline Brucia

  • Knight
  • ***
  • Renown: 29
  • Infamy: 2
  • cRPG Player
    • View Profile
Re: Weird "Error"
« Reply #2 on: December 21, 2017, 11:18:00 PM »
0
It says that my PC doesn't has the minimum requirements to install it :(

Is this new patch really that "advanced"? :o
I can play every other mod, even if i got terrible fps with more than 50 ppl..

Offline Uther Pendragon

  • Supreme Overlord
  • *******
  • Renown: 1247
  • Infamy: 133
  • cRPG Player A Gentleman and a Scholar
  • Head of EU and NA admin teams
    • View Profile
    • Strategus Guide
  • Faction: Stromgarde
  • Game nicks: Uthyr Pendraeg, Uthyr, mr fucking dtv hero admin, Stromgarde_Uthyr_Pendraeg
  • IRC nick: Something along those lines above
Re: Weird "Error"
« Reply #3 on: December 22, 2017, 12:15:13 AM »
+1
I may have linked you the wrong version, try this one

https://www.microsoft.com/net/download/thank-you/net46 it's 4.6, if that doesn't work, try 4.6.2 https://www.microsoft.com/net/download/thank-you/net462

If neither helps, pls report again)))
Nemo prudens punit, quia peccatum est, sed ne peccetur.
I manage character issues, reverting, restoring and fixing related mistakes and some other stuff. Feel free to message if you encounter a problem.
He's not the hero DTV deserves but he's the one they need.

Offline Brucia

  • Knight
  • ***
  • Renown: 29
  • Infamy: 2
  • cRPG Player
    • View Profile
Re: Weird "Error"
« Reply #4 on: December 22, 2017, 11:18:00 AM »
0
Nope...it keep saying that my OS (Windows 7) can't run it

Offline RD_Professor

  • the Deve
  • Supreme Overlord
  • *******
  • Renown: 651
  • Infamy: 29
  • cRPG Player
  • The face of a hero
    • View Profile
Re: Weird "Error"
« Reply #5 on: December 22, 2017, 10:49:03 PM »
0
Nope...it keep saying that my OS (Windows 7) can't run it
Follow the instructions on the OP of this thread, and run the launcher in offline mode. You should be able to play the game fine if you do that.
http://forum.melee.org/announcements/wse2-files-download/

Make sure to run the launcher not in offline mode whenever you start playing for the day to check for a patch. Once you have downloaded the patch, though, run in offline mode.
I am easiest to contact on the cRPG Discord, I am far less likely to respond if you message me on the website or forums.
Steam: http://steamcommunity.com/profiles/76561198051641692

Offline Brucia

  • Knight
  • ***
  • Renown: 29
  • Infamy: 2
  • cRPG Player
    • View Profile
Re: Weird "Error"
« Reply #6 on: December 23, 2017, 04:05:55 PM »
0
I followed the instruction coming from the other post, and thus i've exracted/copied the 3 downloadable files in the M&B Folder, in "CommonRes" and then in the "EN" folder inside languages...but literally nothing has changed: after the replacement of those 3 files, i tried to run the Crpg installer to download the patch, but the usual error come up and i can't even click on "Offline Mode" or anything else, beside closing the Error window (and the crpg launcher with it)...

Offline Zeltino

  • Baron
  • ****
  • Renown: 149
  • Infamy: 9
  • cRPG Player
    • View Profile
Re: Weird "Error"
« Reply #7 on: December 24, 2017, 03:23:30 PM »
+2
This seems to be related to this: http://forum.melee.org/crpg-technical-problems/launcher-error/
Does it say anything else when you try to install the net framework as uther suggested?

And can you check wether you have service pack 1 installed?
(click to show/hide)
If it's already installed, try downloading the net framework again: https://www.microsoft.com/en-us/download/details.aspx?id=53344
If it isn't, follow these instructions: https://support.microsoft.com/en-us/help/15090/windows-7-install-service-pack-1-sp1

Offline Brucia

  • Knight
  • ***
  • Renown: 29
  • Infamy: 2
  • cRPG Player
    • View Profile
Re: Weird "Error"
« Reply #8 on: February 02, 2018, 03:24:15 PM »
+3
Well...it took me some time before doing this, since my pc is really really slow, but i've finally tried it!

And it worked!
Just i have a lot of red writes when the mod is loading which says i don't have textures and other files, but then it seemed to work nicely (even if i tried it just for few seconds tbh)

Anyway really thank you guys! :D

Offline _Tamra_

  • Game Admin
  • *****
  • Renown: 296
  • Infamy: 53
  • cRPG Player
    • View Profile
  • Faction: Greys & Druzhina & Vanguard & Mercs & Krems
  • Game nicks: Tamra & Asha Campana
Re: Weird "Error"
« Reply #9 on: February 02, 2018, 03:52:11 PM »
+2
You can turn off these red warnings, if the game works just fine; fuck those anyway:

In documents : crpg_beta_config

bSuppressPerformanceWarnings=false
bSuppressScriptErrors=false
bSuppressWarnings=false

change to true, donzo.
♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥

Definitely not a fucking forum warrior.

♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥ ♥